FLIR One Developer / Blog / Topics / iOS / Camera stops sending frames after moving to the background

Camera stops sending frames after moving to the background

Home Forums FLIR Mobile SDK Development iOS Development Camera stops sending frames after moving to the background

Tagged: 

This topic contains 5 replies, has 2 voices, and was last updated by Profile photo of Jeff Jeff 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)

  • Author

    Posts

  • #11812

    Profile photo of Jeff
    Jeff

    Participant

    Hi,

    If I’m receiving frames from the camera and the application is sent to the background when I bring it back to the foreground it quits receiving frames. Is there something I need to do during this process with the SDK to get the frames to continue? It seems like the camera is still connected. I’ve tried unsubscribing and resubscribing to the camera, but this doesn’t work. I haven’t tried disconnecting the camera and reconnecting it, but it seems like this shouldn’t be necessary. This happens in the SDK sample app as well. I’m using version 1.0.5 of the SDK.

    Thanks,
    Jeff

    • This topic was modified 9 months, 2 weeks ago by Profile photo of Jeff Jeff.
    • This topic was modified 9 months, 2 weeks ago by Profile photo of Jeff Jeff.

    #18739

    Profile photo of Naoko
    Naoko

    Participant

    Hi Jeff,

    Did you solve this problem?

    I’m having the same problem.I’m using version 1.3.0 of the SDK.

    Thanks,
    Naoko

    #18773

    Profile photo of Jeff
    Jeff

    Participant

    Hi Naoko,

    I’m no longer working on this project, however I believe I resolved this by doing the following.

    #18787

    Profile photo of Jeff
    Jeff

    Participant

    There seems to be an issue with posting information. I’ve tried a couple times over the last few days, but it never works.

    #18801

    Profile photo of Jeff
    Jeff

    Participant

    In Xcode select your iOS target and then choose the Signing & Capabilities tab.<br />
    Down at the bottom there is a series of checkboxes for background modes.<br />

    • This reply was modified 2 months ago by Profile photo of Jeff Jeff.
    • This reply was modified 2 months ago by Profile photo of Jeff Jeff.

    #18817

    Profile photo of Jeff
    Jeff

    Participant

    Sorry, for all the posts. I don’t understand why I can’t make just one post. I keep getting errors.

    • This reply was modified 2 months ago by Profile photo of Jeff Jeff.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.