FLIR One Developer / Blog / Topics / xcode10 libstdc dylib library / Deprecated library (libstdc++) in Xcode 10

Deprecated library (libstdc++) in Xcode 10

Home Forums FLIR ONE SDK Development iOS development Installation and getting started Deprecated library (libstdc++) in Xcode 10

This topic contains 8 replies, has 8 voices, and was last updated by Profile photo of Marshall Marshall 2 months, 3 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)

  • Author

    Posts

  • #7811

    Profile photo of Dani
    Dani

    Participant

    Hi,

    It seems that libstdc++.dylib has been deprecated and not appears in last version of Xcode 10 (https://forums.developer.apple.com/thread/103732).

    The last version of the SDK and Demo Example uses this library. How should continue?

    Thanks,

    Dani.

    #7812

    Profile photo of Marcie
    Marcie

    Participant

    I’ve changed to use the stdc++.tbd library, but am having issues getting image data from the camera. Not sure if that is the cause.

    #7857

    Profile photo of Cem Dogan
    Cem Dogan

    Participant

    I am having issues getting the images after the Xcode 10. libstdc++ is not supported anymore. I tried to copy the latest libstdc++ files from Xcode 9.4 but it couldn’t solve the problem 🙁

    #7893

    Profile photo of Allison
    Allison

    Moderator

    Hi everyone,

    I apologize for the delayed response. In Xcode versions less than 10 using libstdc++.tbd works. If you’re still having image issues please let me know your Xcode version and iOS version. In Xcode 10, we’ve successfully run the sample app included with the latest SDK without linking to libstdc++ if you’re having issues please let me know the iOS version and I will follow up and help you get it working.

    Thank you,
    Allison Torchia

    #8809

    Profile photo of Alexandra
    Alexandra

    Participant

    I just updated to Xcode 10 and I’m facing the same issue whenever I try to run a project that depends on Tesseract using the iOS 12 simulator mykfcexperience.

    Is there any hope that this issue will be fixed (by switching from libstdc++ to libc++) any time soon? This might turn into a bigger deal in the future if left unchecked.

    #8810

    Profile photo of Jame
    Jame

    Participant

    #9567

    Profile photo of TECH
    TECH

    Participant

    Building with libstdc++ was deprecated with Xcode 8 and is not … Xcode 10 cancels the libstdc++ library with built-in the lib so dqfansurvey

    #9945

    Profile photo of Marshall
    Marshall

    Participant

    Add me to the list of people facing this problem after the update..I hope solution is provided soon

    #9948

    Profile photo of Marshall
    Marshall

    Participant

    Still no solution..Waiting for it eagerly

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.