FLIR One Developer / Blog / Topics / Unale to get live image from FLIRONE Pro

Unale to get live image from FLIRONE Pro

Home Forums FLIR Mobile SDK Development Android Development Unale to get live image from FLIRONE Pro

This topic contains 15 replies, has 6 voices, and was last updated by Profile photo of Gavin Gavin 4 weeks, 1 day ago.

Viewing 16 posts - 1 through 16 (of 16 total)

  • Author

    Posts

  • #11526

    Profile photo of Tony
    Tony

    Participant

    Hi all,

    I use sample program from thermal-sdk-android-java-1.0.5 to connect FLIRONE (435-0005-01) and success to get live image. However, I got following message when connect to FLIRONE Pro (435-0011-01):

    Frame buffer creation error: GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT
    Not all framebuffer attachment points are framebuffer attachment complete.

    Actually, the program success to connect camera but unable to get live image from camera.

    I have tried app, FLIR One, from store and the app can display live image from FLIRONE Pro. So, I think my issue does not relate to hardware.

    Would anyone share experience or give me some suggestions?

    Thank you.

    #11529

    Profile photo of Gavin
    Gavin

    Keymaster

    Hi Tony,

    I haven’t seen this issue reported before. I have escalated it to our FLIR Mobile SDK team and hopefully I can have an answer for you in 2-3 days.

    Thanks for your patience,
    Gavin
    FLIR Community Support

    #11569

    Profile photo of David
    David

    Participant

    I’m in the same position as Tony getting the same error message. Have there been any developments or updates regarding this problem?

    EDIT

    Using the sample application I am able to connect the C++ Emulator that displays without issue but the same error message appears when I use the Flir One Emulator.

    In order to get the application to compile, I have had to set the Source Compatability and Target Compatibility to Java 8 (Version_1_8).

    #11570

    Profile photo of Gavin
    Gavin

    Keymaster

    Apologies for the delay but I am still waiting on a response from our technical support team..

    I will update you as soon as I receive an answer.

    Gavin
    FLIR Community Support

    #11578

    Profile photo of Gavin
    Gavin

    Keymaster

    Hi Tony,

    Which device and version of Android are you currently using? Once I know this information our technical support team will be able to resolve the issue.

    Gavin
    FLIR Community Support

    #11579

    Profile photo of David
    David

    Participant

    Are you referring to the phone model or Android OS version?</p>
    <p>The Compile Sdk version in the Project Structure is API 28: Android 9.0 (Pie). This was the setting the project opened on.

    #11583

    Profile photo of sun
    sun

    Participant

    Is this issue solved? I faced the same situation using sdk version 1.0.5.

    #11616

    Profile photo of Gavin
    Gavin

    Keymaster

    Hi David,

    I was referring to both. There has been another similar issue that was found on the Galaxy Tablet A in android 9, which is going to be fixed in the newest release of the SDK coming in a few days.

    Gavin
    FLIR Community Support

    #11655

    Profile photo of Tony
    Tony

    Participant

    Hi all,

    I have run Android sample program from sdk thermal-sdk-android-java-1.1.1 on 3 different devices. Some of devices have issue but not sure is hardware dependent.

    1. Samsung Galaxy, SM-9005, Android 5.0
    can connect camera and get live image of both visual and fusion image

    2. Motorola, Moto E3 POWER, Android 6.0
    Program crash when start running, no UI can be shown. However, App from store is ok

    Following is log:
    04-02 17:49:10.047 4725-4725/com.samples.flironecamera D/OpenGLRenderer: Dumper init 2 threads <0xaf394e40>
    04-02 17:49:10.047 4725-4725/com.samples.flironecamera D/OpenGLRenderer: <com.samples.flironecamera> is running.
    04-02 17:49:10.049 4725-4774/com.samples.flironecamera D/OpenGLRenderer: Use EGL_SWAP_BEHAVIOR_PRESERVED: true
    04-02 17:49:10.050 4725-4774/com.samples.flironecamera D/OpenGLRenderer: CanvasContext() 0xaf7b9000
    04-02 17:49:10.109 4725-4725/com.samples.flironecamera E/ProcessState: Binder driver protocol does not match user space protocol!
    04-02 17:49:10.109 4725-4725/com.samples.flironecamera E/ProcessState: Binder ioctl to set max threads failed: Bad file descriptor
    04-02 17:49:10.109 4725-4725/com.samples.flironecamera A/ProcessState: Binder driver could not be opened. Terminating.
    04-02 17:49:10.109 4725-4725/com.samples.flironecamera A/libc: Fatal signal 6 (SIGABRT), code -6 in tid 4725 (s.flironecamera)

    3. Android Tablet, AOSP on NanoPi 3, Android 7.1.2
    Cam connection is ok but only visual image can be displayed. Fusion image is always blank.

    Compare with log from Samsung Galaxy, there is a difference:
    Tablet (fusion image is blank):
    [atlas_logger] [info] OpenCL is NOT supported, OpenGL ES version 2.0 is supported, CUDA is NOT supported, OpenCV version 3.4.0 is supported, OpenMP is NOT supported
    Samsung:
    [atlas_logger] [info] OpenCL is NOT supported, OpenGL ES version 3.0 is supported, CUDA is NOT supported, OpenCV version 3.4.0 is supported, OpenMP is NOT supported

    Is the issue due to OpenGL ES compatible?

    #11697

    Profile photo of David
    David

    Participant

    Hi All,<br />
    I’ve attempted to use the latest SDK build (v1.1.1) to build the example application, but it keeps failing as it claims to be missing the ConnectionStatus class. The ConnectionStatusListener class is available.

    • This reply was modified 3 months, 4 weeks ago by Profile photo of David David. Reason: additional information

    #11810

    Profile photo of David
    David

    Participant

    Hi All,
    I’ve been able to build and install the example application on my target device. However, whenever I successfully connect to the FLIR One Pro I still get the following error message.

    E/Atlas: [2020-04-14 17:55:31.747] [atlas_logger] [error] [GLBuffer::create]: Frame buffer creation error: GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT
    [2020-04-14 17:55:31.747] [atlas_logger] [error] [GLBuffer::create]: Not all framebuffer attachment points are framebuffer attachment complete.
    [2020-04-14 17:55:31.747] [atlas_logger] [error] Filter “IbpFilter” failed: Invalid input

    #12111

    Profile photo of hyun
    hyun

    Participant

    Hi, Gavin
    Build and run FLIR Mobile SDK (OneCamera-sources)
    The following error message appears.
    Is there a workaround?

    2020-05-28 09:40:30.977 2090-2128/com.samples.flironecamera E/Atlas: [2020-05-28 09:40:30.977] [atlas_logger] [error] [GLBuffer::create]: Frame buffer creation error: GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT
    2020-05-28 09:40:30.977 2090-2128/com.samples.flironecamera E/Atlas: [2020-05-28 09:40:30.977] [atlas_logger] [error] [GLBuffer::create]: Not all framebuffer attachment points are framebuffer attachment complete.
    2020-05-28 09:40:30.977 2090-2128/com.samples.flironecamera E/Atlas: [2020-05-28 09:40:30.977] [atlas_logger] [error] Filter “IbpFilter” failed: Invalid input
    2020-05-28 09:40:31.151 2090-2128/com.samples.flironecamera E/Atlas: [2020-05-28 09:40:31.151] [atlas_logger] [error] [GLBuffer::create]: Frame buffer creation error: GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT
    2020-05-28 09:40:31.151 2090-2128/com.samples.flironecamera E/Atlas: [2020-05-28 09:40:31.151] [atlas_logger] [error] [GLBuffer::create]: Not all framebuffer attachment points are framebuffer attachment complete.
    2020-05-28 09:40:31.151 2090-2128/com.samples.flironecamera E/Atlas: [2020-05-28 09:40:31.151] [atlas_logger] [error] Filter “IbpFilter” failed: Invalid input
    2020-05-28 09:40:31.324 2090-2128/com.samples.flironecamera E/Atlas: [2020-05-28 09:40:31.324] [atlas_logger] [error] [GLBuffer::create]: Frame buffer creation error: GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT
    2020-05-28 09:40:31.325 2090-2128/com.samples.flironecamera E/Atlas: [2020-05-28 09:40:31.325] [atlas_logger] [error] [GLBuffer::create]: Not all framebuffer attachment points are framebuffer attachment complete.
    2020-05-28 09:40:31.325 2090-2128/com.samples.flironecamera E/Atlas: [2020-05-28 09:40:31.325] [atlas_logger] [error] Filter “IbpFilter” failed: Invalid input

    #12135

    Profile photo of jacob
    jacob

    Participant

    I have a FLIR One Pro that’s only a month old.. Was working fine and now it’s ” dead ” the orange light is on but the little charging led above the charge usb C connection does not come on. I have tried already.

    the 30 second reset..

    Let it stay on until it dies and charge, reset again.. no luck..

    opened it up and disconnected the battery , tried again.. no luck

    if the battery is removed and I plug in the charge connection, I still get an orange light..

    nothing visual on the board that I can see that looks to broken/blown..

    Anyone else experience such issue? Any luck with fixing it?

    #12141

    Profile photo of jacob
    jacob

    Participant

    Hi All,
    I’ve been able to build and install the example application on my target device. However, whenever I successfully connect to the FLIR One Pro I still get the following error message.

    E/Atlas: [2020-04-14 17:55:31.747] [atlas_logger] [error] [GLBuffer::create]: Frame buffer creation error: GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT
    [2020-04-14 17:55:31.747] [atlas_logger] [error] [GLBuffer::create]: Not all framebuffer attachment points are framebuffer attachment complete.
    [2020-04-14 17:55:31.747] [atlas_logger] [error] Filter “IbpFilter” failed: Invalid input
    https://100001.onl/ https://1921681254.mx/ https://happymod.site/

    #12271

    Profile photo of David
    David

    Participant

    Hi All,
    I am able to build and install the sample application (v1.2.0) on my target android device SM_G903F. Through debugging I am able to see that the application can detect and connect to the FLIR One Pro. However, it is unable to retrieve and display a live thermal image and the debug log shows the following thermal image.

    W/Atlas: [2020-07-06 11:30:09.049] [atlas_logger] [warning] UsbDriver: Unknown USB_DIR_OUT Endpoint on device! EndpointNumber:6
    D/libEGL: eglInitialize EGLDisplay = 0xffb788e4
    D/libEGL: eglInitialize EGLDisplay = 0xffb787b4
    D/libEGL: eglInitialize EGLDisplay = 0xffb787b4
    E/Atlas: [2020-07-06 11:30:09.420] [atlas_logger] [error] [GLBuffer::create]: Frame buffer creation error: GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT
    [2020-07-06 11:30:09.420] [atlas_logger] [error] [GLBuffer::create]: Not all framebuffer attachment points are framebuffer attachment complete.
    [2020-07-06 11:30:09.420] [atlas_logger] [error] Filter “IbpFilter” failed: Invalid input

    I’ve confirmed that the device works through using the Flir One application available on the Google Play Store.

    #12272

    Profile photo of Gavin
    Gavin

    Keymaster

    Hey David,

    Could you please report your issue here by navigating to technical support > ask a question. This will allow our technical support team to resolve this issue as quickly as possible.

    Thank you,
    Gavin
    FLIR Community Support

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.